Code review comment for lp:~ilidrissi.amine/software-center/fixing-random-bugs

Revision history for this message
Michael Vogt (mvo) wrote :

Thanks for this branch.

I noticed that there are two lines like this:

        if self.adjustment_value is not None \
        and self.adjustment_value <= self.get_vadjustment().lower \
        and self.adjustment_value <= self.get_vadjustment().upper:
            self.get_vadjustment().set_value(self.adjustment_value)

but once its (notice that the >= and <= in the second but "<= and <=" in the
first. Is this a accident? I smells like this should be moved into a single
helper function.

        if self.adjustment_value is not None \
        and self.adjustment_value >= self.get_vadjustment().lower \
        and self.adjustment_value <= self.get_vadjustment().upper:
            self.get_vadjustment().set_value(self.adjustment_value)

The second part of the branch with the translation string clarifications is
great, but not quite suitable for 3.0 because we are in string freeze and this
would fuzzy existing translations. I will move it to trunk instead.

« Back to merge proposal