Code review comment for lp:~lifeless/testtools/0.9.1

Revision history for this message
Martin Pool (mbp) wrote :

You're inconsistent about MisMatch vs Mismatch. Since it's a single English word I would prefer the latter.

107 - if matcher.matches(matchee):
108 + match = matcher.match(matchee)
109 + if not match:
110 return
111 self.fail('Match failed. Matchee: "%s"\nMatcher: %s\nDifference: %s\n'
112 - % (matchee, matcher, matcher.describe_difference(matchee)))
113 + % (matchee, matcher, match.describe()))
114

I would call the variable 'mismatch' otherwise the sense looks inverted.

review: Needs Fixing

« Back to merge proposal