Code review comment for lp:~stevenk/launchpad/db-add-derivedistroseries-api

Revision history for this message
Graham Binns (gmb) wrote :

Final nitpick, otherwise r=me:

> 210 + if displayname is None or len(displayname) == 0:

Why not just use `if not displayname`? (Lather, rinse, repeat for other conditions in this method).

> 211 + raise DerivationError("Display Name needs to be set when"
> 212 + " creating a distroseries.")

When you have to wrap a call, always start wrapping after the opening parenthesis:

    raise DerivationError(
        "Display Name needs to be set when"
        " creating a distroseries.")

(And if the string will fit on one line thereafter, make it so.)

review: Approve (code)

« Back to merge proposal